Infiniti Q30 Forum banner
1 - 20 of 26 Posts

Registered
Joined
17 Posts
Discussion Starter · #1 ·
I bought my Q30 in 2018 and am amazed at the level of gadgets that it is fitted with - that is apart from the rear camera which mine does not have. I have bought a kit but really would like to have the camera show up on the screen rather than have to have another screen . Is there the electronic link to interface the camera into the screen?? I assume this would be a video line that is free - does anyone know if this exists on the Business Exec model Q30 1,5 built 2017.???
 

Registered
Joined
228 Posts
Hi Simple Sailor, great to have you onboard here 馃榿 excuse the pun there 馃枑
I think you are correct, I think if you have the 7" screen and you delve into the service menu it may be possible to change /activate the correct parameter in the car diagnostic menu so it will display a VGA input whilst in reverse.
I think you may not have the parking assist lines but you may see an image.

I will see if I can find the correct menu...

Hope this helps. Cornish 馃憤
 

Registered
Joined
228 Posts
It might be in this menu?
I would access this menu and have a nose about. Hopefully it maybe plain sailing matey 馃樂 sorry another pun...
I think the AV menu would be a good place to start?
I have not used this menu much, only used it once to check if I had any module problems, but all was good.
I did try the speaker test just for fun. I digress.

All the best. Cornish.

Font Rectangle Material property Parallel Screenshot
 

Registered
Joined
17 Posts
Discussion Starter · #4 ·
Hi Simple Sailor, great to have you onboard here 馃榿 excuse the pun there 馃枑
I think you are correct, I think if you have the 7" screen and you delve into the service menu it may be possible to change /activate the correct parameter in the car diagnostic menu so it will display a VGA input whilst in reverse.
I think you may not have the parking assist lines but you may see an image.

I will see if I can find the correct menu...

Hope this helps. Cornish 馃憤
Hi Cornish Blue,
Well that was a nice surprise - thank you for replying and looking into it for me. I have been looking at the trailers for the Q30 for America - the car had options for parking assist and adaptive cruise control years ahead of rivals - such a shame it is not on sale in Europe anymore.
 

Registered
Joined
17 Posts
Discussion Starter · #5 ·
Hi again Cornish Blue,
Have just been out and tried your tips to get into the software - surprise, surprise it worked !!! You certainly know your way around!!! I got to camera but it stated No camera and that seems to be the end - but nevertheless I am very impressed that this software is onboard my Q30 .
Simple Sailor
 

Registered
Joined
228 Posts
Hi again Cornish Blue,
Have just been out and tried your tips to get into the software - surprise, surprise it worked !!! You certainly know your way around!!! I got to camera but it stated No camera and that seems to be the end - but nevertheless I am very impressed that this software is onboard my Q30 .
Simple Sailor
Glad I could help. Yes they are great vehicles, I will do a bit more digging for you. I think the camera maybe possible for you but it will involve connecting to the vehicle with specialist software and running cables which you may not want to do.
I am in a similar quandary I would have loved the better audio, 360 camera and intelligent cruise control but unfortunately i could not find that specification anywhere.
i paid about half the new retail price for my car anyway and it was only 14months old.
Still very pleased as the car is very rare as i am sure you know.
I am just about to do a rear door speaker modification so will post that one up sometime when completed.

Safe and happy motoring. All the best. Cornish.
 

Registered
Joined
9 Posts
If you really want the camera integrated I recommend getting the gator G85VSN. I bought mine from frankies autoelectrics (australia).
Install is relatively simple and it comes with a harness/adapter to plug into the stock entertainment unit.
If you wanted to get tricky I suppose you could try buy the adapter on its own and cut your existing camera in instead.
 

Registered
Joined
228 Posts
Hi, this is not the easiest solution but the info screen has wiring for the camera as per the pictures.
You would need an auto electrician or dealer with software to enable the camera as your car is set to none you say.
Rectangle Font Line Screenshot Parallel


and then run some screened wiring to the boot location?

Product Rectangle Slope Font Parallel
 

Registered
Joined
228 Posts
There is no simple solution to this, the kit seems an excellent option. Unfortunately if your car wasn't originally spec'd with these items you are up against it. I would like internal puddle lights in the door trims but they (nissan / Infiniti / mercedes) didn't even run the looms to them. Its different looms for different spec cars :confused:
 

Registered
Joined
17 Posts
Discussion Starter · #11 ·
There is no simple solution to this, the kit seems an excellent option. Unfortunately if your car wasn't originally spec'd with these items you are up against it. I would like internal puddle lights in the door trims but they (nissan / Infiniti / mercedes) didn't even run the looms to them. Its different looms for different spec cars :confused:
Hello Cornish,
Since our last comms. I have had a very interesting suggestion to buy a Gator G85VSN reversre add on kit which is specifically for the Q30 and QX 30 in Australia - whoever knew!!!!! It seems to state plug and play so am looking with interest at whether to buy this and import - cost about 拢150 - but if it does what it says then it solves the problem. If you get a chance could you look at it and see what you think?? Thanks for your help.
Simple Sailor
 

Registered
Joined
228 Posts
馃枑 Ahoy simple sailor!
This looks like an excellent kit from Gator, it looks to be an additional inline loom which connects to the pins as shown on the posted wiring diagram. Then a long loom to go from display unit to tailgate. Notapplicable has advised they fitted this kit so I wonder if they would mind posting up the instructions that came with the kit?
I am wondering if the touchscreen internal menu will change to the camera option when it knows it has a video signal connection as electronics are clever like that? Again Notapplicable will know.

This all looks very promising.
 

Registered
Joined
228 Posts
Thanks for taking the time to take the photos (aka pushing the boat out 馃対 going the extra (nautical) mile etc ) Notapplicable 馃枑.
I think you might have made Simple Sailors day. Great quality item you have there.馃憤
 

Registered
Joined
17 Posts
Discussion Starter · #15 ·
Since receiving the useful advice from Notapplicable I have checked my software and tried to set up the reverse camera zone and surprise, surprise it has appeared. In other words the software is able to accept a camera and will then show the correct reverse image to supplement parking. Thanks to Cornish and Notapplicable - what
Grille Automotive lighting Vehicle Line Automotive design
team work !!!!!!!!!!!!!!!
 

Registered
Joined
228 Posts
Glad I could help you, I enjoy learning about these great cars 馃枑 post up anytime Mr Sailor 馃憤 and I will try to help again.
We have all gained with this experience. The excellent information from our friend half a world away made all the difference. 馃嚘馃嚭 Safe motoring all 馃檪
 

Registered
Joined
17 Posts
Discussion Starter · #17 ·
Hello Cornish,
This is a bit of a sad story to date so here goes. After finding the G85VSN camera system was specifically designed to fit the Infiniti Q30 I took the step to buy one from down under as the only place you can sourse these systems is Australia. I have had to wait 6 weekd before it arrived and as well as the Aussie VAT and postage I then got hit by HMRC for duty as well followed by a further 拢12 by the Royal Mail!!! - total cost 拢220 ++ ( but don't tell the wife). I tried really hard to find someone to fit the system but no joy so set about it myself - what could go wrong I had very detailed instructions
including photo's . First thing to note was that the Aussie car that was fitted was an automatic - and although it looked similar the Aussie cup holder removed as one piece whereas mine was attached to the gear stick section but I was able to detach and get at the screws etc after that and all went very well. I plugged in the harness and started the engine and as by magic had both the camera working and the reversing area shown on my screen. I therefore put everything back in place on the dashboard and eventually fed the cable through to the rear of the car and after some problems trying to sort the blanking plate re-connected my camera - but in reverse black screen!!!! In addition I have no reversing sensor and the symbol is not showing.
I have tried numerous attempts to open the software to try and see if there is soemthing I can adjust but at the moment it is a sad story with no happy ending in sight. Is there any way to access the software or do I need to strip out the harness and call it a day??
Simple Sailor
 

Registered
Joined
228 Posts
Hi Simple Sailor. All is not lost, things always look better after a cup of tea I find 馃嵉.
It sounds like a wiring or connection issue. I would rope in a friend or colleague and double check everything. I would disconnect the camera from the boot and check for voltage on the cable. You might have shorted a cable and the screen then shuts down? 馃槙
 

Registered
Joined
9 Posts
Oh no. Sounds like something has gone wrong when routing the wiring. Maybe it got badly pinched somewhere?
As per Cornish above it seems the best way forward is to disconnect everything and start from base 1 again. Especially as you had it working initially before feeding the cables.
 

Registered
Joined
17 Posts
Discussion Starter · #20 ·
Hello Cornish and Notapplicable - good of you to both offer advice. I have a further update as I had to go out last night and was in reverse for about 10 seconds when the parking area symbol appeared on the screen - still only a black screen but there appears to be a conflict between the parking sensor and camera. - as for the pinching - that was my concern as we tried to hide the wiring - the plug and socket are only aligned with arrows and the pins are the thinest I have ever seen - there is no chance of getting anything to connect to the pins as they are set deep inside a waterproof socket approx 5 mm wide. I think it is start at the front and see if I can get access to the software by going back to the original plug and try that first - if the cable is pinched/broken then there is nothing I can do so will have to grin and bear it.
This may take a while to get time to tackle once more - will keep you advised once I have tried. Thanks again for your moral support - it does help!!!
Simple Sailor
 
1 - 20 of 26 Posts
Top