Infiniti Q30 Forum banner

Have you heard this?

1 - 3 of 3 Posts

Registered
Joined
5 Posts
Discussion Starter · #1 ·
Hi all, looking for some feedback here.
My Q30s makes a tsss noise when under light acceleration on any gear between approx 1600 & 2200rpm. Sounds more metallic than air.
I can't seem to find boost leaks and had a mechanic mate check out the turbo with me at his shop. There was no play in the shaft, but a little bit of oil and slight signs of wear, somewhat expected at 51,000km.
It is bloody annoying and has me slightly worried a part on the way out. It cannot be heard with the windows up. But is quite noticeable with the windows down or if the car drives past.
Does not make the noise when in neutral and seems easier to trigger when driving up hill on any grade.
Has anyone else noticed similar?

Dealership rant below.
I took it into the Infiniti/Nissan dealership as it was still under warranty. Did a test drive with their technician and we both witnessed the sound (he acknowledged it and said it would be looked into). End of the day they claimed there is no fault and the sound could not be replicated (absolute rubbish, the tech went out with me), I have the paperwork saved. I refused to take the car, but they claimed it was the same on their demo/hire car and therefore must be normal. Again rubbish, never heard similar on any a250 or M270 engine on the road, which I told the dealership and they said they didn't know anything about the M270 engine.......like what!?

TLDR: Has anyone experience similar? Dealership is being a pain and I'd like to gather evidence if possible. Bad quality video below, I had to fiddle with the audio a little as the frequency of the noise is quite high, you can kind of hear it at the 8-9s mark as the vehicle passes the camera up the hill.

Note: If this is normal I'll swallow my words, but would not have purchased the car 3 years ago if I had noticed it. If it is not normal and more widespread then I ask you to vote on the poll so I can show Infiniti and maybe get something done about it.
 

Registered
Joined
168 Posts
Hi NotApplicable, thats a handsome car 馃枑 I have one very much like it 馃槃.
Sorry you are not having much luck with dealer, I am not suprised as they are just not interested in fixing it as it's not that profitable and time is money.
It is certainly not normal as I think IMHO can clearly hear a boost leak from your car as it drives past. As you describe turbo spools up from around 1500 when more torque needed for going up a hill etc, probably will not do it on down hill or steady speed on the flat as boost is very low. I had a similar leak on an old turbo diesel I had found the intercooler hose had a hole in it. Could be as simple as one of the clips loose and hose is not on properly. I would check the hoses and also dump valve area. Could be a hole in the intercooler from a rock but I hope not. If it has been serviced recently could be just something not put back on incorrectly. It is a hard fault to find as it will only show under driving, revving the engine will not create enough boost for you to find it.
Find a garage with a rolling road dyno and book it in for leak checks under load, then you will find it pretty quickly I would say.

Post up what you find.
All the best, Cornish.
 

Registered
Joined
5 Posts
Discussion Starter · #3 ·
Hi Cornish_Blue, they are very pretty aren't they?
I saw one drive past and bought mine the following week 馃槃.
Thanks mate, great idea about using a dyno to check. Next time I can get it booked in at my local I'll ask the guys to give all the tubing and connections a thorough check.
 
1 - 3 of 3 Posts
Top