Infiniti Q30 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi all, this carry’s on from my breakdown post. I’ve now been waiting over two weeks for a new washer pump from my dealership? Is this normal for this car maker, as I can’t belive if my car was in for service it would take this long ?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #2
Just an update, it’s now week 9 ! And yes still waiting for this part to be fitted ?
Also had a call from customer service asking me how my experience was now I have the part fitted ! You couldn’t make this up.
 

·
Registered
Joined
·
5 Posts
Hi Ninjalees, I had a similar issue with no water coming out from the jet. Firstly the dealership said it was the pump but then they checked and found clog in filter. You may ask the dealership to look up the jet filter first.. I waited 6 weeks for the pump but it wasn't.....
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Hi Andy, thanks for the reply. But I’ve had the rac (Infiniti assist) out to fix, and the heating pipe has broken ! And the report has been sent to Infiniti dealership Birmingham and now in week ten still waiting !
 

·
Registered
Joined
·
5 Posts
Hi Ninjalees, I have my filter pump issue fixed finally 2 weeks ago. It ended up not the pump failure but it had something that clogged inside the water container caused by manufacturer (they mixed a window washer liquid in there but it get crystallized in months, thats why it clogged), dealership repair center informed me that they fave removed the water container and filter, then ran it with high pressure water flow for an hour to washed all crystallized pieces away. Perhaps you could ask your dealership to do the same other than just replace the pump and clogging happen again. Help this help!
 
1 - 5 of 5 Posts
Top