Infiniti Q30 Forum banner
21 - 25 of 25 Posts

Registered
Joined
137 Posts
Hi Yoparata, it's not all bad, yes dealers are shockingly bad but hey they all are in my opinion 馃ぃ. Its us that pays for the sales room business rates and staff pay 馃檭
Remember you have GLA mercedes under the body panels, lots of parts just use a vin number or registration from a similar spec GLA 250, A250 and CLA250.
Recently had my car serviced at Nissan dealer, wow most expensive oil change ever I guess. My brake fluid was changed, now my brakes are spongy. I cannot wait until my car is out of warranty. I could have serviced it better myself for a third of the cost and paid for a remap and still had change left over 馃檭. Oil change via dipstick tube no less 馃槷 Yes those brake wear sensor pins are stupid design but get a mercedes one and see if a key place, do you have timsons? They maybe can clone your key? Try Auz motorparts suppliers for brake pads. I like mintex and Borg +beck their webcat will have the equivalent pad references etc. I buy genuine bosch filters too. Mercedes and Nissan dont make their own wear parts as I am sure you know, it's all a big con 馃構 馃憤
 
  • Like
Reactions: Heath

Registered
Joined
1 Posts
Hello
Yes, I had to get Nissan to sort it in the end, they replaced the throttle pedal and sensors; and also repaired the wiring that goes from throttle pedal to the ECM/ECU, along with some connectors which were faulty, in my case it worked and so far so good, but I鈥檓 still monitoring.
Mine was done under warranty, if you don鈥檛 have warranty then it鈥檚 a very costly job, however if you know what needs to be done, saving you the main dealer diagnostics, then even a good private mechanic can do all the above.

Hope this helps
Hi could you confirm that this fix has permenantly solve the warning that you we鈥檙e getting
I might have the same problem
 

Registered
Joined
13 Posts
Discussion Starter · #23 ·
Hi could you confirm that this fix has permenantly solve the warning that you we鈥檙e getting
I might have the same problem
Hello

I can never say 鈥減ermanently鈥 although I hope it鈥檚 a permanent fix, but yes so far so good it hasn鈥檛 returned to date.

If you have to give it in to Nissan and it鈥檚 not within the warranty, then ask Nissan to contact Infiniti on your behalf as they may contribute towards most of atleast half of the costs.

This fault is becoming more common and by now Infiniti should be well aware of it.

good luck
 

Registered
Joined
1 Posts
Hi

Apologies if this has already been mentioned, but for around 4 weeks I鈥檓 getting 2 errors coming up when driving:

鈥淓mergency Brake Inoperative鈥
鈥淚noperative see owners manual鈥

it comes and goes, happened a few times on the motorway where I couldn鈥檛 accelerate normal and it only gradually picked up in speed.

Most times after turning off the engine and starting again after 10 mins cleared the problem, other times even this didn鈥檛 work. I also at times had the engine management light come up alongside these two warnings.

I鈥檝e tried getting the car diagnosed 3 times at costs, but Sod鈥檚 law it wasn鈥檛 showing up at those times, so I was advised no fault found, no error codes etc!

Has anyone else had these faults come up, where they鈥檝e actually had the issue solved?

Any advice/guidance would be really appreciated.

Thanks

View attachment 1543 View attachment 1544
I had same problem mine is a 67 reg 1.5 diesel just bought it when it intermittently appeared garage fixed it says it was a faulty ABS sensor offside front. It used to clear ever time I restarted the car.
 

Registered
Joined
11 Posts
Hi ,



I had the same problems with my 2016 Q30S where the car would not pick up speed properly, only very gradually, when I put my foot down my auto box did not drop a gear automatically so I tried to put the car in sport mode and manually change gear with no luck, it was as if the car was stuck in a high gear, I had to pull off the motorway, turn off the car and lock it for ten minutes then it was fine again.
This happened on another occasion so after a lot of research on this forum and a couple of other electrical issues I had both batteries replaced at my local Nissan dealership.

the car has been running perfectly ever since.

hope that helps.
 
21 - 25 of 25 Posts
Top